Django Migration Error

(Michael Jay Ababao) #1

When I’m trying to migrate my models in Django in MySQL. I always got this error “django.db.utils.ProgrammingError: unsupported operand type(s) for %: ‘bytes’ and ‘tuple’”. Im feeling it was version conflict on mysql and django because i tried to migrate in postgresql and it worked fine.

mysql version = 1.4.2.post1
Django = 2.0.13

0 Likes

(Basil Jose) #2

Django 2.0 supports PostgreSQL 9.3 and higher. psycopg2 2.5.4 or higher is required, though the latest release is recommended.
Django 2.0 supports MySQL 5.5 and higher.

1 Like