I would like to prefix all of my field names, either with a generec “fld_” or with something model specific like “pmt_” for a Payment, examples: “pmt_date”, “pmt_amount”. This would prevent clashing with such fields that I might want to name “type” or “date”. But I can see from documentation that it’s discouraged. Is it just convention? Is there a good way around this other than going to a thesaurus and coming up with goofy alternatives like “kind” instead of “type”?